CVE Details
ID CVE-2019-10903
Summary In Wireshark 2.4.0 to 2.4.13, 2.6.0 to 2.6.7, and 3.0.0, the DCERPC SPOOLSS dissector could crash. This was addressed in epan/dissectors/packet-dcerpc-spoolss.c by adding a boundary check.
References
Vulnerable Configurations
  • cpe:2.3:a:wireshark:wireshark:2.4.0:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.4.0:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.4.1:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.4.1:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.4.2:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.4.2:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.4.3:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.4.3:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.4.4:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.4.4:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.4.5:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.4.5:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.4.6:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.4.6:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.4.7:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.4.7:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.4.8:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.4.8:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.4.9:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.4.9:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.4.10:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.4.10:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.4.11:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.4.11:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.4.12:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.4.12:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.4.13:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.4.13:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.6.0:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.6.0:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.6.1:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.6.1:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.6.2:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.6.2:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.6.3:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.6.3:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.6.4:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.6.4:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.6.5:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.6.5:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.6.6:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.6.6:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:2.6.7:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:2.6.7:*:*:*:*:*:*:*
  • cpe:2.3:a:wireshark:wireshark:3.0.0:*:*:*:*:*:*:*
    cpe:2.3:a:wireshark:wireshark:3.0.0:*:*:*:*:*:*:*
  • cpe:2.3:o:fedoraproject:fedora:29:*:*:*:*:*:*:*
    cpe:2.3:o:fedoraproject:fedora:29:*:*:*:*:*:*:*
  • cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:*
    cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:*
CVSS
Base: 5.0 (as of 02-11-2020 - 21:15)
Impact: 2.9
Exploitability:10.0
CWE CWE-125
CAPEC Click the CAPEC title to display a description
  • An adversary attacks a target by providing input that causes an application to read beyond the boundary of a defined buffer. This typically occurs when a value influencing where to start or stop reading is set to reflect positions outside of the valid memory location of the buffer. This type of attack may result in exposure of sensitive information, a system crash, or arbitrary code execution.
Access
VectorComplexityAuthentication
NETWORK LOW NONE
Impact
ConfidentialityIntegrityAvailability
NONE NONE PARTIAL
CVSS v3.1
Base: 7.5 (as of 02-11-2020 - 21:15)
Impact: 3.6
Exploitability:3.9
Exploitability v3.1
Attack ComplexityAttack vectorPrivileges RequiredScopeUser Interaction
LOW NETWORK NONE UNCHANGED NONE
Impact v3.1
ConfidentialityIntegrityAvailability
NONE NONE HIGH
cvss-vector via4 AV:N/AC:L/Au:N/C:N/I:N/A:P
cvss3-vector via4 CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
refmap via4
bid 107834
fedora
  • FEDORA-2019-77b2d840ef
  • FEDORA-2019-aef1dac6a0
misc
mlist
  • [debian-lts-announce] 20190525 [SECURITY] [DLA 1802-1] wireshark security update
  • [debian-lts-announce] 20201031 [SECURITY] [DLA 2423-1] wireshark security update
suse
  • openSUSE-SU-2019:1356
  • openSUSE-SU-2019:1390
  • openSUSE-SU-2020:0362
ubuntu USN-3986-1
Last major update 02-11-2020 - 21:15
Published 09-04-2019 - 04:29
Last modified 02-11-2020 - 21:15
Back to Top